Author Topic: Ps5 support for reasnow Cross hair  (Read 2034 times)

Geso

  • Newbie
  • *
  • Posts: 5
Ps5 support for reasnow Cross hair
« on: October 09, 2021, 04:06:55 AM »
Hi Richard
I saw many rivals products that is grant support for ps5 such Cronus zen , XIM Apex and others but cross hair not !. Do I have to spend another 120 $ just for S1 ?? Its no fair to force us to buy features that I don't need . I had my cross hair before ps5 release . All rivals was enable to use ps5 support except we with previous cross hair !!! I know the difference between S1 and  cross hair but I don't need all features . just ps5 support like all rivals did it quickly and easy . Please give us answer yes or no for any future updates for previous cross hair

richard

  • Global Moderator
  • *****
  • Posts: 4069
Re: Ps5 support for reasnow Cross hair
« Reply #1 on: October 09, 2021, 04:52:23 PM »
Hi Geso,
Thanks for the feedback!
please note that the competitor of XIM APEX is ReaSnow S1, not our old Cross Hair. :)
but if your Cross Hair can be upgraded to use our APP as explained in the following topic,
you can still get the PS5 support.
http://www.reasnow.com/forum/index.php?topic=2575.0

Geso

  • Newbie
  • *
  • Posts: 5
Re: Ps5 support for reasnow Cross hair
« Reply #2 on: October 11, 2021, 06:10:57 PM »
Thanks for helping me and giving me hope
But is APP capable only to cross hair V4.X.X
? Because my cross hair under V4

richard

  • Global Moderator
  • *****
  • Posts: 4069
Re: Ps5 support for reasnow Cross hair
« Reply #3 on: October 11, 2021, 06:21:57 PM »
the hardware version of your cross hair?

Geso

  • Newbie
  • *
  • Posts: 5
Re: Ps5 support for reasnow Cross hair
« Reply #4 on: October 11, 2021, 09:45:52 PM »
Cross Hair
----------------------------
Manager Ver:1.73.74
GameEngine Ver:1.31.0
Macro Ver:1.10.0
Hardware Ver:1.7.5
Firmware Ver:1.73.74
BootLoader Ver:1.22.0

richard

  • Global Moderator
  • *****
  • Posts: 4069
Re: Ps5 support for reasnow Cross hair
« Reply #5 on: October 12, 2021, 04:27:20 PM »
sorry, your cross hair is a pretty old one,
and it is not compatible with our new software!